Fórmulas para Excel: do básico ao avançado![LISTA COMPLETA]
Share on twitter
Share on linkedin
Share on facebook

Conhecer novas fórmulas para Excel é um passo importante para você automatizar boa parte do seu trabalho. Afinal, pode ser bastante cansativo trabalhar com planilhas, não é verdade?.

Pode parecer exagerado, mas imagine se você precisar lidar com centenas ou milhares de dados precisando selecionar, organizar e registrar um por um para contabilizar. Você poderia demorar semanas para fazer isso, se não fossem as fórmulas para Excel.

Esse tipo de recurso foi criado justamente para facilitar o processamento de dados que são inseridos na ferramenta. 

Desde as mais complexas até as fórmulas mais simples, todas podem ajudar no dia a dia de trabalho de qualquer empresa.

Com o Excel, inclusive, você pode fazer até um controle de estoque automatizado para o seu negócio. Consegue imaginar o quanto isso pode facilitar a vida de sua equipe?

De fato, falar em fórmulas pode parecer algo complicado e difícil de entender, mas não se assuste! Inserir comandos no Excel é muito mais simples do que você imagina

E para você ir pegando o jeito, vamos começar este artigo pelas fórmulas básicas do Excel. Só depois partiremos para comandos um pouco mais complexos, mas que também não são nenhum bicho de sete cabeças, ok?

Segue com a gente, então, e aprenda como fazer planilha no Excel com fórmulas variadas.

9 conjuntos de fórmulas para Excel, suas variações e o passo a passo para usar cada uma delas

Separamos em tópicos as principais fórmulas do Excel para que você organize todo o seu trabalho, de forma simples.

Para facilitar a sua leitura, dividimos as fórmulas para Excel da seguinte forma:

  1. Fórmulas básicas do Excel para realizar somas, subtrações, multiplicar ou dividir;valores
  2. Recurso AutoSoma;
  3. Fórmulas para calcular a média;
  4. Fórmulas para fazer contagem;
  5. Fórmulas para saber o maior e o menor valor de um intervalo;
  6. Fórmulas para usar células de diferentes planilhas dentro do mesmo arquivo;
  7. Fórmulas para calcular porcentagem;
  8. Fórmula para unir informações de duas ou mais células;
  9. Fórmulas com a função SE.

Entenda, a seguir, como usar cada uma destas fórmulas para Excel.

1. Fórmulas básicas do Excel para realizar somas, subtrações, multiplicar ou dividir valores

Vamos começar pelas fórmulas mais simples do Excel, que são as fórmulas em que você usa matemática básica.

Considere que existe um conjunto de valores em uma planilha e que seja necessário somá-los.

Para isso siga os passos abaixo:

  1. 1. Selecione a célula onde você quer que o resultado de sua soma apareça;
  2. 2. Nessa célula digite o sinal de igual (=) para iniciar a fórmula;
  3. 3. Em seguida, digite (ou selecione) as células que deseja somar. No nosso exemplo, vamos imaginar que queremos somar as  células B2 e B3, como no exemplo abaixo:

=B2+B3

Simples assim! Reforçando: essa fórmula deve estar na célula em que você deseja que o resultado apareça. 

Você pode adicionar outras células na soma, para isso basta começar com o sinal de igual (=) e ir adicionando as células que você deseja somar. Por exemplo:

=B2+B3+B4+B7+C5

Para você fazer cálculos como subtração, multiplicação ou divisão, basta adicionar os sinais correspondentes como nos respectivos exemplos abaixo:

=B2-B3

=B2*B3

=B2/B3

Essas são as fórmulas básicas do Excel.

Usando este mesmo princípio você também pode usar a sua planilha como uma calculadora, substituindo a referência das células por números. Como nos exemplos abaixo:

=15+10

=50-25

=10*50

=100/2

Assim que você escrever estas fórmulas e apertar o ENTER no teclado, a célula irá retornar os valores desejados.

Essas fórmulas são ótimas opções para quando você precisa fazer contas simples em momentos que possui apenas poucos dados.

Para planilhas com muitos valores, ou muitas células, será necessário que você adicione um comando antes de suas contas, e dessa forma tenha acesso a mais recursos.

E para ter acesso a mais recursos basta usar a seguinte fórmula para Excel:

=SOMA()

Agora basta adicionar dentro dos parênteses as mesmas fórmulas usadas anteriormente, porém sem precisar adicionar o sinal de igual (=) novamente. Ficando assim:

=SOMA(B2+B3)

Essa fórmula para Excel diz ao programa que você está adicionando uma conta matemática dentro do parênteses. Facilitando por exemplo o uso de recursos como este exemplo abaixo:

=SOMA(B2:B7)

Nesta fórmula acima você está usando o sinal de dois pontos ( : ) para dizer ao programa que você quer a soma de todos os valores que estão ENTRE as células B2 até a B7.

2. Recurso AutoSoma

O recurso AutoSoma te ajuda a agilizar somatórios simples sem precisar escrever as fórmulas de soma que vimos anteriormente.

Basta que você selecione as células que precisa somar e clique no botão de AutoSoma, que fica, normalmente, no conjunto de ícones do canto superior direito da “Página Inicial” do Excel.

Isso vai te poupar bastante trabalho.

3. Fórmulas para calcular a média

Além das contas matemáticas básicas você também pode descobrir a média de um conjunto de valores..

Para a média você pode usar algumas fórmulas diferentes, de acordo com o seu propósito. Essas são umas das principais fórmulas do Excel.

A fórmula para tirar uma média simples é:

=MÉDIA(B2:B7)

Com acento mesmo.

Neste exemplo o resultado é a média dos valores das linhas 2 ao 7 da coluna B.

Também é possível descobrir a média dos valores, ignorando qualquer zero que for encontrado. Basta adicionar um argumento à fórmula, que vai ficar assim:

=MÉDIASE(B2:B7; “<>0”)

Para você descobrir um valor Mediano em um conjunto de valores, ou seja, o número do meio, você pode usar a seguinte fórmula:

=MED(B2:B7)

Já para descobrir o Modo, que é o número que ocorre com mais frequência dentro de um conjunto de valores, você utiliza a fórmula:

=MODO(B2:B7)

4. Fórmulas para fazer contagem

Fazer uma contagem de dados utilizando fórmulas para Excel vai te ajudar em diversos momentos. Principalmente quando você estiver lidando com muitas entradas em sua planilha.

Quando lidamos com volumes grandes de dados, é necessário ter uma fórmula que faça este trabalho e que, principalmente, possa ser integrada a outras – e assim agilize o seu trabalho.

Para realizar uma contagem você deverá utilizar a seguinte fórmula para Excel:

=CONT.SE(B2:B30;”João”)

No exemplo acima você está procurando quantas vezes a palavra “João” aparece no intervalo entre B2 a B7. Observe que logo após colocar o intervalo B2:B30 é utilizado “;” (ponto e vírgula) para separar o critério que será utilizado na contagem.

Ou você pode usar uma dessas variações:

=CONT.SE(B2:B30;A5)

Nesse caso, ao invés de especificar o texto por extenso, você está indicando que busca pelo que está escrito em uma célula, apontando para ela. Neste exemplo, o conteúdo da célula A5.

=CONT.SE(B2:B30;“<100”)

Aqui o critério passa a ser valores menores que 100, e também precisa vir entre aspas.

=CONT.SE(B2:B30;“>=100”)

Esse caso de uso funciona de forma similar ao critério anterior, porém indicando valores maiores ou iguais a 100.

Há também a possibilidade de contar quantas células possuem informação (ou seja, não estão em branco). E para isso você pode contar quantas células possuem números ou textos e números. 

Veremos primeiro a fórmula usada para contar apenas as células que contenham números:

=CONT.NÚM(C8:E12)

Abaixo, você encontra a fórmula para contar todas as células que contenham qualquer tipo de informação como números ou textos.

=CONT.VALORES(C8:E12)

Se sua necessidade é contar, provavelmente algumas dessas fórmulas irão te ajudar.

5. Fórmulas para saber o maior e o menor valor de um intervalo

Uma outra fórmula para Excel muito utilizada é a fórmula que procura o maior ou o menor valor em um determinado intervalo.

Para descobrir estes valores você tem duas fórmulas:

=MÍNIMO(C8:E12)

=MÁXIMO(C8:E12)

Cada uma delas vai retornar o valor mínimo ou máximo encontrado dentro das células entre C8 ou E12.

6. Fórmulas para usar células de diferentes planilhas dentro do mesmo arquivo

É bem provável que você tenha diversos dados distribuídos por diversas Planilhas (abas) diferentes dentro de seu arquivo do Excel. E, claro, pode precisar buscar informações de células que estejam em planilhas diferentes.

Para resolver isso é muito simples. Basta conhecer este comando do Excel que você conseguirá referenciar em quais células e planilha estão as informações que você precisa.

Vamos supor que você tenha as abas: Planilha1 e Planilha2, e quer fazer um somatório de um dado da Planilha 1 com dados da Planilha2, que você está utilizando no momento.

Para isso, basta você escolher a célula que você quer que o resultado seja exivbido e escrever a fórmula da seguinte maneira:

=SOMA(Planilha1!C8;+B2)

Com isso você somará a informação da célula C8 da Planilha 1 à célula B2 da planilha atual.

Outras formas de fazer as somas de valores de diferentes lugares:

=SOMA(Planilha1!C8+Planilha1!D8;+B2)

Dois valores da Planilha 1 (C8 e D8) e um valor (B2) da planilha atual.

Ou um conjunto de valores como:

=SOMA(Planilha1!C8:E12;+B2:B4)

Nesse caso, os valores lançados entre C8 e E12 da Planilha1 foram somados aos valores que estão entre B2 e B4 da planilha atual.

Como você pôde ver nos exemplos acima, basta adicionar o nome exato da planilha onde está o dado que você precisa, e usar o ponto de exclamação ( ! ) para separar a referência de planilha da referência do intervalo de células.

Se o nome da planilha contiver espaços ou números, será necessário adicionar apóstrofos ( ‘ ) antes e depois do nome da planilha. Como no exemplo abaixo:

=SOMA(‘Vendas Noturnas’!C8;+B2)

7. Fórmulas para calcular porcentagem

Para calcular porcentagem é bem simples e tudo o que irá precisar é usar uma fórmula matemática junto com os princípios que já viu por aqui.

Vamos usar a imagem abaixo como referência de nossas contas:

Neste exemplo, é possível ver as vendas de dois colaboradores e o percentual de comissão que cada um recebe.

Para retornar o valor correto a receber basta utilizar a fórmula descrita na imagem:

=B2*(C2/100)

Onde B2 é o valor da venda multiplicado por C2 dividido por 100 para dar o valor em porcentagem.

8. Fórmula para unir informações de duas ou mais células

Há muitas situações nas quais você pode querer unir informações de diferentes células dentro em apenas uma célula. Este é um cenário bastante comum, por exemplo, em relatórios, cujo objetivo é reunir as principais informações da planilha em um só lugar. 

Para isso também existe uma fórmula para Excel. A fórmula concatenar:

=CONCAT(A2;” “;D2)

O exemplo acima realiza a ação de listar a informação da célula A2 ,adicionar um espaço e em seguida inserir a informação da célula D2, tudo em uma única linha de texto.

Se você aplicar esta fórmula à situação ilustrada pela imagem de referência mais acima, você teria:

José R$3.000,00

Onde José representa A2 e os R$3.000,00 a célula D2.

Você pode usar a fórmula para Excel CONCAT de diversas formas, conforme sua necessidade e criatividade.

9. Fórmula com a função SE

A função SE é muito útil para facilitar a interpretação de algum dado, retornando uma informação direta.

Ela permite que você use comparações lógicas entre valores e atribuir dois lançamentos: um para resultado verdadeiro ou outro para resultado falso.

Vamos ver em um exemplo:

Como você pode ver na imagem a fórmula usada é:

=SE(B2<35000;”Abaixo da meta”;”Meta atingida”)

Neste exemplo acima, a fórmula diz que: Se for verdadeiro que o valor da célula B2 é menor que 35000, a célula deve exibir o texto “Abaixo da meta”. Caso seja falso (ou seja, caso o valor seja maior que 35000), então a célula deve exibir o texto “Meta atingida”.

Funciona basicamente assim:
=SE(teste_lógico;[valor_se_verdadeiro];[valor_se_falso])

Ou seja, no primeiro momento adicione uma informação que pode ser verdadeira ou falsa, e logo em seguida coloque os resultados que deseja mostrar caso seja verdadeiro ou falso.

Usando o que já aprendemos nas fórmulas para Excel anteriores podemos representar a função SE, também, das seguintes formas:

=SE(A2=”José”;”Sim”;”Não”)

Aqui você tem a informação de que: se na célula A2 estiver escrito José retorne a palavra Sim, caso contrário Não.

=SE(B2>B3;”Vendeu mais”;”Vendeu menos”)

Já nesse caso você usou a informação: se B2 for maior que B3, resultará na mensagem Vendeu mais, caso contrário Vendeu menos.

Pronto para deixar sua próxima planilha de Excel ainda melhor?

E aí?! Ficou mais fácil saber como fazer planilha no Excel com fórmulas como estas que te ensinamos acima?

Esperamos que sim!

Seja com fórmulas básicas do Excel ou fórmulas avançadas, o importante é estar sempre evoluindo! Executar novos comandos no Excel é sempre empolgante!

Neste artigo, trouxemos algumas das principais fórmulas do Excel, e temos certeza de que elas serão muito úteis para o seu dia a dia.

Mas, para que você possa ir além e tornar seu uso do Excel ainda mais inteligente, que tal conectá-la a outras ferramentas gratuitamente?! 

Com esses recursos você vai poder organizar o financeiro, utilizar sua planilha como um centro de coleta e compartilhamento de informações em tempo real e gerenciar tarefas e processos.

Ficou curioso? Acesse nossa página e vamos colocar sua planilha do Excel no automático!

Conheça todas as integrações que a Pluga desenvolveu para automatizar suas planilhas, sem que você precise se preocupar com uma linha de código sequer. 

Esse artigo foi útil para você? 😎
Média: 5 / 5

Você também pode gostar

Os diferentes tipos de gatilhos mentais estimulam a tomada de decisão de potenciais clientes. Empresas de todos os setores podem usar esse recurso ao […]